Miliony użytkowników systemu Android na całym świecie będzie zmuszonych do zakupu nowego telefonu. Dlaczego? Otóż to jedyny sposób na zabezpieczenie się przed poważną luką w chipie, negatywnie wpływającą na ogromną liczbę urządzeń.

Google zaktualizowało swoje produkty i systemy tak, aby chronić użytkowników przed zaistniałymi problemami i lukami, które umożliwiały hakerom kradzież prywatnych danych. Firma twierdzi, że smartfony i tablety z zielonym robotem, które mają zainstalowane najnowsze aktualizacje zabezpieczeń są chronione przed lukami powstałymi w układach Intel, AMD i ARM.

Jednak znaczna część smartfonów z systemem Android, takich jak Samsung czy LG jest – i zawsze będzie – starsza. Nieobsługiwane wersje systemu operacyjnego nadal pozostają zagrożone.

Jeśli tak rzeczywiście jest, oznacza to, że miliony użytkowników, którzy utknęli na starszych wersjach systemu Android, będą mogli zapewnić sobie bezpieczeństwo, zastępując swój telefon nowszymi modelami z aktualnymi wersjami zielonego robota.

The Independent zwrócił się do Google z prośbą o komentarz, aczkolwiek jak na razie brak wypowiedzi giganta.

Android jest fragmentarycznym tworem, ponieważ wykorzystuje się go na wielu urządzeniach różnych producentów. Firmy te często wprowadzają poprawki do systemu operacyjnego, aby promować własne usługi i produkty. W związku z tym, zanim wydadzą użytkownikom aktualizacje oprogramowania, może minąć bardzo dużo czasu.
Z kolei smartfony Google, takie jak Pixel i Nexus, działają na czystej wersji Androida. To oznacza, że otrzymują aktualizacje, gdy te będą dostępne.

Od 11 grudnia 2017 roku ponad 20% użytkowników zielonego robota utknęło na wersjach systemu operacyjnego, które nie otrzymują już aktualizacji zabezpieczeń od Google. Należą do nich KitKat, Jelly Bean, Ice Cream Sandwich i Gingerbread – wszystkie zostały wydane ponad 4 lata temu.

Google ujawniło, że od maja 2017 roku na świecie jest aktywnych ponad dwa miliardy urządzeń z systemem Android. Wyniki te sugerują, że istnieje setki milionów smartfonów i tabletów, które mogą zostać narażone na ataki hakerów.